What am I doing wrong here?

Get help using Construct 2

Post » Wed Sep 12, 2012 1:16 pm

Here's a copy of a stripped down version of my capx.
CapX

When it counts off in the database the x variable works fine. The Y seems to lose a digit. It should be everytime the y variable passes the number of records variable the y should reset back to the stsrting y position. But it resets back to the y position + 1 instead. I'm sure it's something relatively easy but with a lack of sleep I can't seem to place my finger on it.
B
68
S
21
G
15
Posts: 701
Reputation: 15,604

Post » Thu Sep 13, 2012 1:17 am

Anyone around able to figure out what I'm doing wrong with my conditions? I know that the php side works fine as it uploads tiles in the right format.
B
68
S
21
G
15
Posts: 701
Reputation: 15,604

Post » Thu Sep 13, 2012 2:02 am

I don't fully understand what you're doing there but I guess setting NextY to int(StartingYPos.Text) in event 8 makes event 9 true, which then adds 1 to NextY. Deactivating the group in event 8 wont stop the rest of the events in the group from running.
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,020

Post » Thu Sep 13, 2012 2:14 am

@ramones What I want to do is this. Say I enter 1 and 1 for the x and y and set the number of records to 3. I want to first start by filling in positions by the x mark so x1y1,x1y2,x1y3 then when y reaches the record amount set x to the next item and reset y. So x2y1,x2y2,x2y3 The do it again one last time with the x variable set to 3. Then when x and y are both filled completely(9 records) I want it to stop.
B
68
S
21
G
15
Posts: 701
Reputation: 15,604

Post » Thu Sep 13, 2012 2:34 am

@ramones,

I switched checking to two groups, one for x and one for y based on what you thought and you were right. :):):) Thanks bud :)
B
68
S
21
G
15
Posts: 701
Reputation: 15,604

Post » Thu Sep 13, 2012 2:42 am

Nice one.
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,020


Return to How do I....?

Who is online

Users browsing this forum: austinblackbelt, makkancs and 35 guests