Why are these sprites moving smother without WebGL?

Get help using Construct 2

Post » Wed Aug 24, 2016 2:53 pm

https://dl.dropboxusercontent.com/u/191 ... _test.capx
https://drive.google.com/file/d/0B6abl_ ... =drive_web

If you preview it should open without WebGL on Internet Explorer, you'll notice a few objects with bullet behavior moving very slowly but smoothly to the left.
Change renderer to WebGL, now these sprites aren't moving smoothly anymore, it's like they are skipping pixels or avoiding subpixels.
On Chrome it doesn't matter, it doesn't move smoothly with and without WebGL. Firefox works just like Internet Explorer.
It feels like it's forcing Pixel rounding or something when I activate WebGL.

I want to be able to have smooth movement of sprites even when they are moving very few pixels at a time.
How can I achieve this with WebGL? Thanks.
Last edited by Xavier on Wed Aug 24, 2016 8:16 pm, edited 1 time in total.
B
75
S
29
G
17
Posts: 256
Reputation: 15,250

Post » Wed Aug 24, 2016 7:32 pm

Your dropbox account is under pressure.

Error (429)
This account's links are generating too much traffic and have been temporarily disabled!
B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Wed Aug 24, 2016 7:53 pm

Don't use WebGL.
B
56
S
15
G
13
Posts: 826
Reputation: 17,705

Post » Wed Aug 24, 2016 8:16 pm

I've added a google drive link.
B
75
S
29
G
17
Posts: 256
Reputation: 15,250


Return to How do I....?

Who is online

Users browsing this forum: JaredX and 23 guests