Why does apply Force at angle not work?

Just started using Construct 2? Post your questions here

Post » Thu Mar 19, 2015 2:22 pm

Hello,
following event:
force.PNG


Set angle and Physics enabled works, but the force doesnt. The player just falls down because of the gravity.
The only thing i notice is if I set force to a high number like 1000, the Players spins very fast.

Any idea why this is happening?

thanks in advance
You do not have the required permissions to view the files attached to this post.
B
5
Posts: 23
Reputation: 261

Post » Fri Mar 20, 2015 9:59 am

Probably because you're only applying the force for 1 frame. Try using "apply impulse" instead.
B
55
S
28
G
18
Posts: 1,520
Reputation: 25,285

Post » Fri Mar 20, 2015 12:17 pm

Great, that works, thank you :)

I have an other problem, maybe you can help me with that too:

a.PNG


This should let the player reappers on the other side layout if he is outside. I took it form the "Template: Infinity Jumper".
After the player reappers on the other side, he just falls down. Like he losts his force. Any idea how i can change that?
You do not have the required permissions to view the files attached to this post.
B
5
Posts: 23
Reputation: 261

Post » Fri Mar 20, 2015 2:46 pm

Yeah if you teleport an object with physics behavior it loses it's velocity. You can store the old values and then restore them afterwards like this:

Edit: The forum isn't letting me add attachments...

Image
https://dl.dropboxusercontent.com/u/836 ... ocity.capx
B
55
S
28
G
18
Posts: 1,520
Reputation: 25,285

Post » Fri Mar 20, 2015 3:54 pm

Wow great, thank you very much :) Works like a charm
B
5
Posts: 23
Reputation: 261


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 2 guests