why does this hinge stop working?

For questions about using Classic.

Post » Mon Sep 21, 2009 6:47 am

hello everyone :D

just recently started messing with construct and gotta say this is one amazing program. last friday i ran into a problem and i couldn't create a workaround using construct's tools, couldn't find documentation related to this problem so i thought i'd post here :)

what i want to do: create a rope-like object dangling from another object with 8direction behavior.

what i did: http://www.4shared.com/file/134211570/3 ... /rope.html

i created two sprites: one for the "rope" (it's just one long line, no joints/articulation), one for the 8direction control. set both of them to physics behavior, added gravity to the "rope" and added a hinge using an imagepoint at the top of the "rope" sprite, to be connected to the center of my 8direction sprite. set my 8direction sprite to immovable so the gravity pulling the "rope" down wouldn't drag the other sprite.

great, it works! :D but only very briefly :(

as you'll see in the example i created, if you start moving the sprite immediately after the layout creation, you'll get the expected behavior. if you snooze, though, it simply won't work: the 8direction sprite will move but the hinge will not work properly, leaving the "rope" floating in the air (even though it was supposed to fall), motionless.

so i tried a workaround for this problem: i won't set the 8direction sprite to immovable, i'll simply reset its position back to a fixed coordinate, so it'll stay there, "immovable". the problem is that the "rope" is still affected by gravity and it's Y velocity keeps growing until it stabilizes at ~130, making for a jerky "rope" :(


i really just wanted to be able to use the first solution, but if there's a fix to the workaround so that the rope won't keep flickering up and down, that would work too :D any help is appreciated and thanks in advance :P

edit: created with 0.989, tested with the same results on 0.9942 and 0.995
Posts: 4
Reputation: 833

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests