Why I can't build my app at Intel XDK?

Get help using Construct 2

Post » Thu Oct 20, 2016 9:25 pm

Hi guys,


I have tried to build my game today in Intel XDK. I have the mewest version of Intel XDK and Construct2. I have insert the plugins I need (social sharing, facebook and admob). I have put the pass to build. I have choose the certificate....

But the build failed over and over again....

I develop only for android. I choose all the options in the construct2 in the section cordova export (hide status bar, use wkwebview on ios, use new intel xdk project format, overwrite .xdk roject files).

I can't solve this problem... can you help me please?
B
16
S
2
Posts: 35
Reputation: 816

Post » Thu Oct 20, 2016 9:49 pm

The build log say this:

"FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':processArmv7ReleaseManifest'.
> Manifest merger failed : uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library [com.facebook.android:facebook-android-sdk:4.14.1] .../builds/build.2016-10-20.21-43-05.AM2a3V.tmp/cordova_project/platforms/android/build/intermediates/exploded-aar/com.facebook.android/facebook-android-sdk/4.14.1/AndroidManifest.xml
Suggestion: use tools:overrideLibrary="com.facebook" to force usage

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output."

BUILD FAILED"

Can someone help me?
B
16
S
2
Posts: 35
Reputation: 816

Post » Tue Oct 25, 2016 8:54 pm

I have the same problem.
B
20
S
10
G
10
Posts: 143
Reputation: 7,096

Post » Tue Oct 25, 2016 9:23 pm

makkancs wrote:I have the same problem.


I discover the solution today.

Try this: in the API field in the configurations, delete 14 and insert 15.

Solve your problem?
B
16
S
2
Posts: 35
Reputation: 816


Return to How do I....?

Who is online

Users browsing this forum: DiegoSanudoDT, R0J0hound and 10 guests