Why it happens in this case?

Get help using Construct 2

Post » Sun May 18, 2014 12:37 pm

SET.jpg


What happens:
it starts to play "Correct" for 1 sec from the beggining again and again ... sound like it get stuck.
After it starts to play all of songs same time but it shouldn't do that

GO=2
if song = 2 > Play song 2
etc...

What i want:
Play correct ONE time and wait 1 sec(duration of correct sound and the animantion is about 1 sec)
then choose a number to "Song" and play ithe song which includes that number.

Help please.
You do not have the required permissions to view the files attached to this post.
B
4
Posts: 29
Reputation: 262

Post » Sun May 18, 2014 12:54 pm

And if i set it like this:

Set2.jpg


It almost good but not at all... starts to play a random song and after 1 sec it starts to play from beginning.
You do not have the required permissions to view the files attached to this post.
B
4
Posts: 29
Reputation: 262

Post » Sun May 18, 2014 1:57 pm

Try putting a trigger once while true condition with your Sytem Go =3
B
46
S
23
G
31
Posts: 693
Reputation: 20,637

Post » Sun May 18, 2014 2:42 pm

Yeah your problem is that while ever Go = 3 the app is calling your displayed code over and over and over again.

rekjl is exactly right, popping trigger once in your conditions should sort your problem out!
B
13
S
6
Posts: 130
Reputation: 1,553

Post » Sun May 18, 2014 4:10 pm

Thank you both!
Works perfectly now :)
B
4
Posts: 29
Reputation: 262


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 5 guests