Why it moves so jerkingly?

Just started using Construct 2? Post your questions here

Post » Sun Oct 30, 2016 9:30 am

I use small sprites, the biggest of them is 64x64. The problem is when the camera moves(or objects are moving) they do it with some jerking\shaking. Also this is visible when the camera moves.

You can see it on the video(on the video it does not look so horrible, but in the realtime play does): YouTube
At 0:10 look at the big gray square stone's edge.
Sometimes you can even see a background through the gaps that these jerkings make
B
6
S
1
Posts: 17
Reputation: 475

Post » Sun Oct 30, 2016 2:46 pm

Found this thing.
When the player makes some steps - a gap at the edge of the stone appears - make some steps again - it disappears.
How do u people make your games without these annoying things?
In debug mode it says that the x and y coordinates of the gray stone are not changing.
Image
B
6
S
1
Posts: 17
Reputation: 475

Post » Sun Oct 30, 2016 3:21 pm

It is virtually impossible to diagnose a problem from just images and a video.

Please consider posting a .capx so we can test for ourselves and hopefully offer a useful solution.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,380
Reputation: 58,442

Post » Sun Oct 30, 2016 3:35 pm

zenox98 wrote:It is virtually impossible to diagnose a problem from just images and a video.

Please consider posting a .capx so we can test for ourselves and hopefully offer a useful solution.

Here it is
But there is almost nothing inside. Just a platform behaviour
B
6
S
1
Posts: 17
Reputation: 475


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 0 guests