wierd rendering problem on canvas 2D -Solved

Get help using Construct 2

Post » Thu Oct 30, 2014 3:33 pm

Hi fellow constructors... I've run into a strange bug i hadn't noticed in my bubble game.. see image ->
bubbleproblem2.png


as you might notice all sorts of sprites are shown to the left of the game window .. (it's actually all the sprites & spritefonts used in the current layout... ) i did not place these objects my self and as far as i can see they are not registred in the debugger as objects ...

It only happens using canvas 2d all seems well on webGL - and if i rotate the ipad so it goes to portrait and then back to landscape (or resize browser window) they disappear (and the white bars turn black) ...


Do any of you have an idea about whats going on - and more importantly how to fix it ???

EDIT
found out what was happening-

i had all my layers set to transparent because they are fully populated with sprites..
but i had also set the project property : Clear Back ground - to "no" ... that made all the visible objects to be shown in the screen ... manual explains it like this ->
"If all layouts are completely obscured by sprites or other objects, you can also set all layers to transparent to skip both clears every tick. However, in this case, any areas not covered by objects will appear glitchy or full of garbage pixel data."

i managed to solve it by just leaving the bottom layer opaque

funny thing though was that all the pixel garbage seemed to disappear if i forced the canvas to resize :/

anyhow hope this can help somebody if they find them self in a similar situation
You do not have the required permissions to view the files attached to this post.
Image
Get it on Google play or play on papio.nu
B
11
S
2
Posts: 79
Reputation: 786

Return to How do I....?

Who is online

Users browsing this forum: Blendi1223, jatin1726, Kyatric and 21 guests