Wild Chrome Browser Performance Vs Node Webkit

Discussion and feedback on Construct 2

Post » Thu Mar 07, 2013 12:04 pm

In Chrome on my browser I'm getting about 30 FPS but when I export and run on the desktop via Node Webkit I easily get 60 FPS.

Has anyone else experienced this?
B
39
S
12
G
8
Posts: 580
Reputation: 7,108

Post » Thu Mar 07, 2013 1:36 pm

Node webkit isn't chrome , awesomium was chrome ... It was reported less powerful by Scirra , I forgot where they wrote that but you get the point ...

Cheers...
B
35
S
16
G
16
Posts: 2,222
Reputation: 16,589

Post » Thu Mar 07, 2013 1:38 pm

It's chromium though isn't it? Are they not essentially the same thing?
B
39
S
12
G
8
Posts: 580
Reputation: 7,108

Post » Thu Mar 07, 2013 1:44 pm

Well, I don't know the major differences between the two

But Node is chromium combined with node.js ..

@Ashley ?Whiteclaws2013-03-07 13:49:03
B
35
S
16
G
16
Posts: 2,222
Reputation: 16,589

Post » Thu Mar 07, 2013 2:48 pm

Node-webkit is basically the Google Chrome browser (strictly speaking, Chromium). It has node.js features as well, but we don't use them much with Construct 2 (yet). It seems to work a lot better than Awesomium for us, even though they are supposed to be very similar.

Both Chrome and node-webkit v-sync their display. So if you get 59 FPS, in some circumstances it will get worst-case v-sync interaction and fall all the way to 30 FPS. So it's likely the difference is actually very small.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Sun Mar 10, 2013 11:29 pm

@Ashley

Can we get some heads-up on what node.js features are you thinking about?
Be nice until it's time to not be nice
B
36
S
9
G
9
Posts: 293
Reputation: 6,652

Post » Mon Mar 18, 2013 10:11 am

@Ashley - so in Chrome browser my game is consistently 30fps and through Node-WebKit it's 60fps consistently.

Is this a bug with Chrome then?
B
39
S
12
G
8
Posts: 580
Reputation: 7,108

Post » Mon Mar 18, 2013 1:10 pm

No, as I said in my post it is most likely actually a very small difference, but it's interacting badly with V-sync.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Mar 18, 2013 8:23 pm

Okay, is this typically indicating a performance issue with my game? Just trying to figure out how to fix the issue.CrudeMik2013-03-18 20:23:50
B
39
S
12
G
8
Posts: 580
Reputation: 7,108


Return to Construct 2 General

Who is online

Users browsing this forum: Lof and 1 guest