win8 WindowsStoreProxy.xml wrong

Bugs will be moved here once resolved.

Post » Thu May 23, 2013 2:25 pm

The exported WindowsStoreProxy.xml contains an error:

[code]
<?xml version="1.0" ?>
<CurrentApp>
<ListingInformation>
    <App>
      <AppId>00000000-0000-0000-0000-000000000000</AppId>
      <LinkUri>http://apps.windows.microsoft.com/app/00000000-0000-0000-0000-000000000000</LinkUri>
      <CurrentMarket>en-US</CurrentMarket>
      <AgeRating>7</AgeRating>
      <MarketData xml:lang="en-us">
        <Name>Full license</Name>
        <Description>Purchase the app</Description>
        <Price>4.99</Price>
        <CurrencySymbol>$</CurrencySymbol>
      </MarketData>
      <!-- Include to test product listings -->
      <!--
      <Product ProductId="my_product_id">
        <MarketData xml:lang="en-us">
          <Name>My Product</Name>
          <Price>1.99</Price>
          <CurrencySymbol>$</CurrencySymbol>
        </MarketData>
      </Product>
      -->
    </App>
</ListingInformation>
<LicenseInformation>
    <App>
      <IsActive>true</IsActive>
      <IsTrial>true</IsTrial>
      <ExpirationDate>2013-06-01T05:00:00.00Z</ExpirationDate>
    </App>
     <!-- Include to test product purchases -->
     <!--
     <Product ProductId="my_product_id">
          <IsActive>false</IsActive>
     </Product>
     -->
</LicenseInformation>
</CurrentApp>
[/code]

Should be:

[code]
<?xml version="1.0" ?>
<CurrentApp>
<ListingInformation>
    <App>
      <AppId>00000000-0000-0000-0000-000000000000</AppId>
      <LinkUri>http://apps.windows.microsoft.com/app/00000000-0000-0000-0000-000000000000</LinkUri>
      <CurrentMarket>en-US</CurrentMarket>
      <AgeRating>7</AgeRating>
      <MarketData xml:lang="en-us">
        <Name>Full license</Name>
        <Description>Purchase the app</Description>
        <Price>4.99</Price>
        <CurrencySymbol>$</CurrencySymbol>
      </MarketData>
</App>
      <!-- Include to test product listings -->
      <!--
      <Product ProductId="my_product_id">
        <MarketData xml:lang="en-us">
          <Name>My Product</Name>
          <Price>1.99</Price>
          <CurrencySymbol>$</CurrencySymbol>
        </MarketData>
      </Product>
      -->
    
</ListingInformation>
<LicenseInformation>
    <App>
      <IsActive>true</IsActive>
      <IsTrial>true</IsTrial>
      <ExpirationDate>2013-06-01T05:00:00.00Z</ExpirationDate>
    </App>
     <!-- Include to test product purchases -->
     <!--
     <Product ProductId="my_product_id">
          <IsActive>false</IsActive>
     </Product>
     -->
</LicenseInformation>
</CurrentApp>

[/code]
B
29
S
9
G
6
Posts: 525
Reputation: 8,294

Post » Thu May 23, 2013 3:20 pm

Oops, looks like you're right. Should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,508


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests