Windows 10 Phone and Back Button Behaviour

Discussion and feedback on Construct 2

Post » Thu Oct 22, 2015 12:16 am

Hi folks,

In Windows Phone 8.1 using universal app, we could use the Event for Browser Back Button. For Windows 10, this seems to not work. When I press the back button, my app just minimizes. If I try the app on Windows 8.1, the back button works like it should (calling the Browser Back Button event).

Has anyone experienced this, or knows how to make the back button work properly?
B
42
S
18
G
8
Posts: 495
Reputation: 8,410

Post » Thu Oct 22, 2015 7:09 am

probably a bug but win10 is still in development for mobile phones, i heard release date is somewhere mid december, stay on 8.1 until 10 is out, it's the best suggestion i have.
Sea Monsters template - Isometric
Also includes 40 pages PDF of optimizations and "how-to" for your games, and how the "sea monsters" template was built. Follow link for details :)

sea-monsters-templates-and-assets_t162705
B
42
S
14
G
12
Posts: 624
Reputation: 9,421

Post » Thu Oct 22, 2015 8:42 pm

saiyadjin wrote:probably a bug but win10 is still in development for mobile phones, i heard release date is somewhere mid december, stay on 8.1 until 10 is out, it's the best suggestion i have.


I imagine it is a bug. Just getting some of my apps ready for Windows 10.
B
42
S
18
G
8
Posts: 495
Reputation: 8,410

Post » Fri Oct 23, 2015 1:59 pm

Try listening for keyboard key ESCAPE. This may or may not work. But I know the keyboard equivalent is that key.
B
90
S
18
G
9
Posts: 2,455
Reputation: 15,018

Post » Thu Nov 05, 2015 2:16 am

Any news? I'm trying to export my apps for Windows 10 Mobile!
B
86
S
25
G
11
Posts: 652
Reputation: 11,051

Post » Thu Nov 05, 2015 3:00 am

Iolva wrote:Any news? I'm trying to export my apps for Windows 10 Mobile!



I have not had time to look into it
B
42
S
18
G
8
Posts: 495
Reputation: 8,410

Post » Sun Jan 03, 2016 2:03 pm

@Ashley I still have not figured this one out. Any ideas?
B
42
S
18
G
8
Posts: 495
Reputation: 8,410

Post » Mon Jan 04, 2016 12:01 pm

If you think it is a bug, please file it in the Bugs forum following all the guidelines.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762

Post » Thu Jan 07, 2016 10:00 pm

Ashley wrote:If you think it is a bug, please file it in the Bugs forum following all the guidelines.


That is the thing, I am not sure if it is a bug. I was hoping you could comment on if this is intended behavior.
B
42
S
18
G
8
Posts: 495
Reputation: 8,410


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 6 guests