Windows 8 App performance vs IE 10 desktop

Discussion and feedback on Construct 2

Post » Tue Apr 30, 2013 1:34 am

I'm in the process of testing a game I have created for the windows 8 app store. I've added a FPS and render method text to the app and see that desktop IE 10 is rendering canvas2d as expected. Also, the FPS is 58-60fps. When I export to windows 8 and run as an application I am only seeing 35FPS while everything is in motion.

Why such a big difference between IE10 desktop and IE10 in a Windows 8 App.

Please help.

Thanks.

B
8
S
2
G
1
Posts: 4
Reputation: 1,085

Post » Tue Apr 30, 2013 2:40 pm

In theory it should be the same, but I think @thehen is aware of some Win8 app bugs that cause poor performance. I think MS are aware of it and Windows 8.1 may fix it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,630

Post » Tue Apr 30, 2013 7:49 pm

That's not what I wanted to hear. :-(

I was planning to present at a conference of Microsoft developers on building games for Windows 8 with Construct 2.

I guess I have to really trim back my game.

Does anyone know what specific features I would need to stay away from? I removed all the physics behaviors in an attempt to speed up but that did not yield much. I guess all I have left is to reduce the number of sprites.

Thanks.
B
8
S
2
G
1
Posts: 4
Reputation: 1,085

Post » Tue Apr 30, 2013 8:47 pm

do you test in visual studio ? I have a big perfomance drop when launching my app from visual studio but works good when launching from the start menu
B
12
S
3
G
4
Posts: 63
Reputation: 3,410

Post » Wed May 01, 2013 12:31 am

BINGO! (And I don't mean BING+O)

Launching through visual studio was the problem. I'm back to the same performance as IE 10 on the desktop.

Thanks so much.
B
8
S
2
G
1
Posts: 4
Reputation: 1,085

Post » Wed May 01, 2013 12:35 am

I hope Internet Explorer 11 uses WebGL could integrate webGL in Windows 8 app
B
96
S
25
G
20
Posts: 3,055
Reputation: 22,646

Post » Wed May 01, 2013 12:56 am

Yeah, always test direct as an app as opposed to running through visual studio when gauging performance. VS does a lot of debug stuff that slows it down.
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,428

Post » Fri Jun 21, 2013 11:44 pm

One quick note on this...I was helping another dev out during my Office Hours today, who was running into this perf issue, on a game using the Physics behavior.

Something that might not be obvious (I missed it initially), you can get the same improvement in performance even running from Visual Studio if you use the "Run without debugging" (Ctrl+F5) command.

Switching the build from debug to release won't help, if you still run in debug mode from VS.

B
4
Posts: 11
Reputation: 477


Return to Construct 2 General

Who is online

Users browsing this forum: Aphrodite, eli0s and 7 guests