windows 8 - sound problems

Discussion and feedback on Construct 2

Post » Mon Apr 07, 2014 7:39 am

After realizing that I need a windows 8 computer to make windows 8 games, I decided to try exporting my games as a html 5 website and playing them with a windows 8 surface. This works well for the most part, but I can't get any sound to work!
Is there any way to get sound working on a windows 8 surface?
I'm running windows 8.1 on my surface and the sound seems to be working fine.

Thanks in advanced. Let me know if there's any other information needed and I'll try to supply it as quickly as possible!
B
12
S
2
Posts: 39
Reputation: 1,082

Post » Mon Apr 07, 2014 7:43 am

I just tried one of the demo games on my surface and the sound worked fine *scratches head*
B
12
S
2
Posts: 39
Reputation: 1,082

Post » Mon Apr 07, 2014 7:57 am

If one of the C2 examples works, then it implies that your implementation is sonehow in error.

Maybe just try to recreate a very simple .capx and test. If it doesn't work, then upload for us to test.

The usual problem with sounds is to do with encoding, See the following post response from Ashley:

https://www.scirra.com/forum/failure-to-import-mono-wav_p763895?#p763895
If your vision so exceeds your ability, then look to something closer.
Moderator
B
136
S
31
G
87
Posts: 5,494
Reputation: 60,274

Post » Mon Apr 07, 2014 9:51 am

Thanks for the fast response!
I will try a few tests and if I'm unsuccessful, will upload some examples.

The weird thing is that it works fine on my pc running windows 7 :s
B
12
S
2
Posts: 39
Reputation: 1,082

Post » Tue Apr 08, 2014 3:40 pm

Okay, I made a little test program.
This program works on my computer but still doesn't work on my Windows 8 surface.

Links:
online: http://users.tpg.com.au/docdrd/LukeApps ... index.html
Dropbox (.capx): https://www.dropbox.com/s/hpyaeatk4jr5u ... s%208.capx

I used a high and low quality sound that I input into the "sound" and "Music" folder. All work on my PC running windows 7 but none of them work on my windows 8.1 surface.
The "Touched" text is just to let me know that an input was received on my surface.

Let me know if there's any more info needed as I'm determined to figure this one out.
B
12
S
2
Posts: 39
Reputation: 1,082

Post » Wed Apr 09, 2014 12:03 pm

I tried some of the construct 2 demo games on my windows 8.1 surface
http://www.scirra.com/construct2/demos
The sound worked on all of them except for "Moon Shield"

This is so weird. There must be something different about the sound in Moon Shield and the way I'm implementing my game. I've played around a bit but just can't seem to figure this one out!
B
12
S
2
Posts: 39
Reputation: 1,082


Return to Construct 2 General

Who is online

Users browsing this forum: AlexiarTW, tumira and 10 guests