Windows 8.1 universal application seems crashing on phone

Discussion and feedback on Construct 2

Post » Sat Apr 04, 2015 7:51 pm

Hi ,

This is first time i am working for windows phone 8.1 , When i debug my application the very first initial warning i see is as below

Code: Select all
Warning     1     Warning : DEP0810 : This app references Microsoft.Phone.WinJS.2.1, version 1.0.9651.0, found in your SDK, but you have a higher version of Microsoft.Phone.WinJS.2.1 installed on the target machine, 1.0.9651.40228. If you continue to run this application, it will run against the currently installed version, Microsoft.Phone.WinJS.2.1, version 1.0.9651.40228. Consider updating your SDK to match the version of Microsoft.Phone.WinJS.2.1 that is installed. http://go.microsoft.com/fwlink/?LinkId=260891     AqlODil.WindowsPhone


I have installed the latest windows phone SDK and it has all kinds of newest version. But for some reason i am unable to change the reference SDK and i find no way to change this at all ..but since it was just a warning it did not stop like an error.

After that it started loading the screen with progress bar and i see following errors

Code: Select all
HTML1701: Unable to add dynamic content '<select msallowclip=''><option selected=''></option></select>'. A script attempted to inject dynamic content, or elements previously modified dynamically, that might be unsafe. For example, using the innerHTML property to add script or malformed HTML will generate this exception. Use the toStaticHTML method to filter dynamic content, or explicitly create elements and attributes with a method such as createElement.  For more information, see http://go.microsoft.com/fwlink/?LinkID=247104.

WEBGL11135: getContext: Context attribute depth:false is not currently supported


Then it suddenly , quietly close the application by it self and sometime it displays the main screen of my game and then it close that application.

I thought it is happening because my application is using much memory but according cpu debug construct2 i see main screen takes only 12 mb with 15 objects and avg cpu usage 15%.

I thought its was my application problem so i have compiled and exported the spaceblaster game from construct2. This game ran on the windows phone fine , but when more sprites came on the screen the game started getting slower and again the app closed by it self.

What could be the reason behind? My phone is nokia lumia 720 windows 8.1 and i have 2.20 gb free and i am not using any sd card. I do not get any error in console when i debug through visual studio except the above i listed...

Kindly help
B
9
S
2
Posts: 108
Reputation: 1,010

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests