Windows Data Execution Prevention crashes C2?

Discussion and feedback on Construct 2

Post » Tue Sep 10, 2013 4:54 am

Hey guys, I'm having a little problem with DEP with C2. C2 crashes for me about 1-3 times a day, and for a while I thought it was because I was on a pretty modest laptop. But I'm trying C2 on a desktop with a quad core, 4GB RAM, nice video card, sound card, etc. The only piece that isn't really great is that I'm running Windows Vista.

And there comes the problem. It seems that Windows likes to shut down C2 pretty regularly. I'm not 100% sure what is causing it, so I can't post a capx with instructions to replicate. It does seem to happen most often when I'm running in preview in a browser, and <Alt><Tab> while in C2.

I've tried to change the settings for DEP in Windows, but it doesn't allow me to add an exception for C2 for some reason. And I'd rather not turn it completely off.

Any ideas?
B
10
S
4
G
1
Posts: 58
Reputation: 1,420

Post » Tue Sep 10, 2013 9:00 am

If you can replicate what happens, post that to bugs for Ashley to see.
B
226
S
60
G
33
Posts: 902
Reputation: 39,989

Post » Tue Sep 10, 2013 9:54 am

Are your graphics card drivers up to date?
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,454

Post » Tue Sep 10, 2013 4:51 pm

My laptop's integrated graphics card had the most recent drivers it could have. I just checked my desktop and the drivers were from January, but there are more recent ones. I've installed them, and will update you in a few days to a week how it goes.
B
10
S
4
G
1
Posts: 58
Reputation: 1,420

Post » Fri Sep 13, 2013 12:11 am

Still crashing with the latest Nvidia drivers. Twice in two days. Yesterday it said DEP again, today there wasn't a reason given.
B
10
S
4
G
1
Posts: 58
Reputation: 1,420

Post » Fri Sep 13, 2013 12:37 pm

I had these exact same issues with Vista, just constant DEP errors, I managed to reduce them by removing some old graphics card drivers and updating my current ones. But that did only reduce the crashes to about 2 a day, there was no way to stop them completely. I even tried a fresh install of Vista, no luck.
It's fixed now, but I'm afraid my solution was to upgrade to Windows 8
B
15
S
5
Posts: 141
Reputation: 1,657


Return to Construct 2 General

Who is online

Users browsing this forum: R0J0hound and 10 guests