Windows Phone 8 low quality images problem

Get help using Construct 2

Post » Sat Aug 31, 2013 4:01 pm

Hi, I am making a game for Windows Phone 8 and when I export the project so I can test it with Visual Studio on my Windows Phone device the result is showing bad low quality images. I don't know what to do! Here I have a screenshot of the game and how it looks on my device

https://skydrive.live.com/redir?resid=795F9B70661EF4D5!204&v=3

And here are the settings in Construct 2 and Visual Studio

Construct 2

Pixel Rounding: On
Window Size: 800,480
Fullscreen in browser: Letterbox scale
Sampling: Linear

Visual Studio

System.Tray.Visible: False
Supported Orientation: Landscape
Orientation: Landscape
B
2
Posts: 7
Reputation: 164

Post » Sat Aug 31, 2013 6:32 pm

I had this exact problem just yesterday with Landscape. My problem was both the bad graphics and my game wasn't centering on the screen.

Here is what I did.

Open up the Index.html in Visual Studio
In the Style tag area, just before the </style> add

@-ms-viewport {
width: device-width;
}



ArcadEd2013-08-31 18:32:38
B
101
S
32
G
12
Posts: 1,549
Reputation: 21,993

Post » Thu Sep 05, 2013 11:01 am

[QUOTE=ArcadEd] I had this exact problem just yesterday with Landscape. My problem was both the bad graphics and my game wasn't centering on the screen.

Here is what I did.

Open up the Index.html in Visual Studio
In the Style tag area, just before the </style> add

@-ms-viewport {
width: device-width;
}



[/QUOTE]

Ohhhhhhhhhhhh!!!!!!!!!! Thank you very much!!!!!!!! You are the best!!!!
B
2
Posts: 7
Reputation: 164

Post » Thu Sep 05, 2013 1:12 pm

From what I've read, that fix will not work for all devices. IIRC it also looks fine by default on the WP8 devices I've tested. Are you sure that will work for all devices?
Scirra Founder
B
402
S
238
G
89
Posts: 24,628
Reputation: 196,023

Post » Thu Sep 05, 2013 2:24 pm

In my Windows Phone Plugin I use:

@-ms-viewport { width: 100%; }

Looking back I'm not sure why I opted for that over device-width.

@Ashley any source on that not working for all devices? I can't find any reference in MS documentation.

Cheers!thehen2013-09-05 14:25:00
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,945

Post » Thu Sep 05, 2013 6:11 pm

@thehen - I read somewhere it makes the Lumia 920 go too wide... hmm...

Is that the only change necessary to index.html to fix it? Are there any other changes that would be useful to make?Ashley2013-09-05 18:11:40
Scirra Founder
B
402
S
238
G
89
Posts: 24,628
Reputation: 196,023

Post » Thu Sep 05, 2013 6:18 pm

We're using width:100% for Mortar Melon and we tested on the 920 with no issues. That was the only change I added to index.html as far as I can tell.
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,945

Post » Thu Sep 05, 2013 6:44 pm

I actually have a Lumia 920 as my phone and test device and it worked fine either way.

First build I sent in was the code I posted above. When it failed cert because of the back button, I resubmitted using theHen's plugin/project files and it still worked fine.


ArcadEd2013-09-05 18:45:21
B
101
S
32
G
12
Posts: 1,549
Reputation: 21,993


Return to How do I....?

Who is online

Users browsing this forum: draiza and 8 guests