Windows Phone 8.1 app with audio crashes on suspend/resume

Bugs will be moved here once resolved.

Post » Wed Mar 09, 2016 1:40 pm

Problem Description
A project exported as Windows 8.1 Universal, running on Windows Phone 8.1 with audio runs, but then crashes on resume part of suspend/resume.
Ie. App runs with audio playing on phone. User navigates to homescreen, then uses back button to resume app. Instead of resuming, the app crashes. (Same result if phone is locked/unlocked - the app crashes).

The "workaround" that I ended up applying to my final published game app on the Windows Store for Windows Phone 8.1 was to remove *ALL* the audio files and events from the game - which results in the app suspending/resuming normally, without crashing.

NB. The same issue *does not* occur with a Windows 10 Universal exported project running on Windows 10 Phone.
The issue seems specific to the app running on Windows Phone 8.1 (it doesn't occur with Windows 8.1 PC version either).

Attach a Capx
https://onedrive.live.com/redir?resid=8 ... der%2ccapx

Description of Capx
Contains 2 Object Types: Audio and Browser.
Contains 2 Events which start audio playing when loaded, and continue audio when app resumes:

1. System, On Start of layout - Audio Play long looping at volume 0 dB (tag"")
- Audio Play Snap looping at volume 0 dB (tag"")

2. Browser, On resumed - Audio Play long looping at volume 0 dB (tag"")
- Audio Play Snap looping at volume 0 dB (tag"")

Note that the "Snap" audio takes a few seconds to start once the project is loaded.

Steps to Reproduce Bug
  • Export Project as Windows Store, target version Windows 8.1 Universal.
  • Load exported project into Visual Studio (I used Community 2015 Version 14.0.24720.00 Update 1).
  • In Solution Explorer, right click on "Bug_demo.WindowsPhone (Windows Phone 8.1)" and select "Set as Startup Project". Save.
  • Open package.appmanifest of the Windows 8.1 project and in the packaging tab add a (test) certificate to enable project to be successfully built. Save.
  • Manually copy code of Publisher tag across from Windows package.appmanifest to Phone packageappmanifest. Save.
  • Connect a Windows 8.1 Phone device via USB.
  • Change build options in Visual Studio to "Release" "ARM" and "Device".
  • Build project and Deploy to phone.
  • When loaded on phone, audio will play (repeating low hum and snap sound). Stop debugging in Visual Studio and quit project, disconnecting phone from USB.
  • Load app on phone. Audio will play.
  • To reproduce bug: press home button to navigate to home screen. Then, press back button and switch back to app. Instead of resuming, the app crashes.
  • A second way to reproduce bug is to load app then lock phone. Unlock phone, and instead of the app resuming it crashes.

Observed Result
The app crashes, instead of resuming.

Expected Result
Expected the app to resume.

Affected Browsers
  • Windows 8.1 Phone: YES (Exported from Construct 2 as Windows Universal 8.1).
  • Windows 10 Phone: NO (Exported as Windows Universal 10).
  • Windows 8.1 PC and Windows 10 PC: NO (Exported as either Windows Universal 8.1 or 10).
  • Chrome: N/A
  • FireFox: N/A
  • Internet Explorer: N/A

Operating System and Service Pack
PC: Windows 10 Pro, 64 bit, Version 10.0.10586 updated to 9 March.
Phone: Microsoft Lumia 535, Windows Phone 8.1 Update version 8.10.14234.375

Construct 2 Version ID
Construct 2 Release 224 (64-bit) checked, built on 3 March 2016 Personal license.

Hope that you can investigate.
Thanks.
B
2
Posts: 2
Reputation: 154

Post » Tue Mar 22, 2016 3:17 pm

Closing as this isn't a bug in Construct 2 if the app crashes, since it's not normally possible for our code to do that - it's most likely a bug in Windows Phone. Please report it to Microsoft instead.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests