WKwebview + Cordova Admob plugin + Intel XDK = black screen

Discussion and feedback on Construct 2

Post » Tue Dec 27, 2016 10:43 am

Hi,

I'm trying to publish my game on IOS with the latest intel xdk. I can build the app without problems, but in the simulate tab it stucks on a black screen. But as the simulate tab is not a real device, i installed it on my IOS device (IOS 9.3.2) but it only shows a blackscreen after the splashscreen. After debugging the app on simulate tab, one of the errors pointed me to something related to Admob plugin and another error pointed to WKwebview (Uncaught TypeError: Cannot read property 'messageHandlers' of undefined ... plugins/cordova-plugin-wkwebview-engine/src/www/ios/ios-wkwebview-exec.js:123)

So i decide to remove the Admob plugin from intel xdk, wkwebview plugin still there, then the game runs fine on the simulate tab and on the device. But with no ads (of course). I was using 'cordova-plugin-ad-admob' for ads, also tried 'cordova-plugin-admob', without success.

Then i tried to reinstall the 'cordova-plugin-ad-admob', still the same, so i removed WKwebview from plugins and it worked as well. Showing ads!

This 2 plugins are not working together?!!!

As a last try, i installed Cordova Admobfree plugin for C2, made the changes to the C2 code and tried with it...exported, added intel xdk plugin 'cordova-plugin-admob-free'...still a blackscreen!

Just to give you some more details:

- I'm using C2 personal v. 241(Steam), Win10-64bit, Intel XDK 3759;
- Tried exporting with and without minifying + WKwebview;
- There is no problem in the game code cause it is already published on google play. I did remember to change the Banner and Intersticial ID's on C2, test mode 'true'.

Some help will be greatly appreciated! Thanks!
B
14
S
5
Posts: 110
Reputation: 1,338

Return to Construct 2 General

Who is online

Users browsing this forum: Colludium, Glyfos and 2 guests