WP8 Export: Fullscreen not being set

Bugs will be moved here once resolved.

Post » Sat Jan 11, 2014 9:05 am

Link to .capx file (required!):
[Not needed nor helpful, but I do have helpful screenshots below]

Steps to reproduce:
1. Open C2/WP8 file located at C2\exporters\html5\wp8\MainPage.xml
2. In the top-level tag, the following code is always set to true, rather than being a variable so that it can change between true and false.

Observed result:
shell:SystemTray.IsVisible="True"
This causes an extra side in apps to always have a "black bar" where the system tray would be.

(Using a letterbox scale)


Expected result:
I would expect the gameplay area to use up more of the screen when I choose a fullscreen scaling option. So, when I change WP8 code to
shell:SystemTray.IsVisible="False" ...

(Using a letterbox scale)


Browsers affected:
Chrome: n/a
Firefox: n/a
Internet Explorer: n/a

Operating system & service pack:
Windows 8.1 Enterprise, 64-bit

Construct 2 version:
Tested in r154, r155, 156


- Danial Goodwin -

ps - I'm not sure if it is in the WP8 guidelines, that the status bar always has to be visible. But, my past three WP8 apps have been certified/published on the first try with `shell:SystemTray.IsVisible="False"`. Also, this basically just the first method that I found that works for getting to fullscreen. There may or may not be more solutions.
B
20
S
4
G
1
Posts: 185
Reputation: 2,563

Post » Mon Jan 13, 2014 5:11 pm

You're right, hiding the system tray would be a better default than showing it. Made the change for the next build.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest