wrap issue

Bugs will be moved here once resolved.

Post » Mon Oct 03, 2011 11:08 pm

I hope I can explain what I mean

I observe a strange issue. I have 3 clouds, they are moving and should wrap at the end of the layout. Actually it works fine.
until a while , then it do stop working. I mean during the author time. I have not changed at these events and should also work, but wrap behaviors do not not work more. When I created my clouds new then it works again for a while.   
B
21
S
5
G
5
Posts: 163
Reputation: 5,028

Post » Mon Oct 03, 2011 11:27 pm

http://dl.dropbox.com/u/36472942/construct/forumhelp/sprite-wrap-moveforward.capx
Works for me.
Probably you're doing something strange somewhere with your clouds.

Also instead of setting to a low float variable (0.1 px) you should rather try a formula containing dt.
Try "dt * 6" or another value.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Mon Oct 03, 2011 11:56 pm

With dt the same issue. What I mean, it work for me too, but after few times not more.

strange too, now wrap one cloud , but the another not , although all have the same event and so.

Probably you're doing something strange somewhere with your clouds.

these are normal png files

very strange for me
B
21
S
5
G
5
Posts: 163
Reputation: 5,028

Post » Tue Oct 04, 2011 12:47 am

Post your capx.
In my example you can let clouds go on forever and they always wrap.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Tue Oct 04, 2011 7:50 am

Yes I see your exemple ,and I think it not different as my

anyway here is my project

Before that was all working. Now is only one cloud working I do not understand why not more all clouds do wrap.

http://www.mjmedia.de/hasispiel1.capxhttp://www.mjmedia.de/hasispiel1.capxvidi2011-10-04 07:56:23
B
21
S
5
G
5
Posts: 163
Reputation: 5,028

Post » Tue Oct 04, 2011 8:35 am

I used clouds in my last demo game posted on these forums "Bomber", and all i did was use the bullet behaiour on them and set them at low speeds. And added Wrap and they seem to work fine.
B
40
S
14
G
11
Posts: 243
Reputation: 9,432

Post » Tue Oct 04, 2011 9:21 am

Whether bullet dt or move forward, my clouds do not wrap more after some time later.

I have not idea why .
B
21
S
5
G
5
Posts: 163
Reputation: 5,028

Post » Tue Oct 04, 2011 11:22 am

This copy of your capx works OK. I just changed the z-order.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,850
Reputation: 48,301

Post » Tue Oct 04, 2011 5:57 pm

Here a video so you can see only cloud No2 works . I do not understand why
http://mjmedia.de/wrap/wrap.html
B
21
S
5
G
5
Posts: 163
Reputation: 5,028

Post » Tue Oct 04, 2011 6:32 pm

@vidi
It is bizarre. I re-amended your .capx and added some code. It showed the clouds X-position getting stuck just off screen, implying perhaps a bug somewhere, maybe in the Wrap behavior.

I moved the Origin to the far left, and added boundary check and it appears to work for me now.zenox982011-10-04 18:55:27
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,850
Reputation: 48,301

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 8 guests