Wrap issue?(not similar to the ones I've seen)

Bugs will be moved here once resolved.

Post » Sun Oct 30, 2011 4:54 pm

Hey everyone. I'm having an issue with my character getting "stuck" during wrapping. Sometimes he doesn't appear on the other side. Also when jumping from the top of the screen, like in the demo level below, he doesn't reappear at the bottom of the screen. Not sure if it's a bug or something I'm doing wrong. If you jump around awhile on the top platform you'll see what I mean.

Demo Stage

.cpx -> Hereeochranek2011-10-30 16:55:23
B
9
S
1
G
2
Posts: 21
Reputation: 1,950

Post » Mon Oct 31, 2011 7:18 am

What is your browser ? OS ?
I've tried the link "Demo Stage" on FF 7.0.1 in win XP, the wrapping appeared to work in every levels.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Post » Fri Nov 04, 2011 5:32 pm

I've attempted a fix for the next build. When it comes out can you let me know if it fixes it? Thanks.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Wed Nov 09, 2011 1:58 pm

Is this fixed in r67 by any chance?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Mon Nov 14, 2011 3:34 pm

I've since transitioned into just writing the wrap ability into the event sheet as "if x >= 640, then x = 1". I tried switching back to just assigning the character the wrap behavior after r67, but it still glitches at the top of the screen. He just sort of jitters for a second then comes back down on the platform without ever coming up at the bottom of the screen. Thanks for the reply.

B
9
S
1
G
2
Posts: 21
Reputation: 1,950

Post » Sun Jan 22, 2012 6:23 pm

Hello, I seem to be having a very similar problem with the wrap behavior. It'll go to wrap around the X axis but then it'll jitter most of the time. Then wrap oddly. I've used Firefox and Chrome. (Chrome seems to work much better with Construct 2 because when I test in Firefox the whole game screen will flash that's sort of off topic but just thought I'd mention that.) And you also asked what OS we're using. I'm on Windows 7 64 bit. And I'm running the newest build of Construct 2. Is this a bug still or am I doing something wrong?
B
16
S
2
G
1
Posts: 28
Reputation: 1,346

Post » Fri Jan 27, 2012 6:39 pm

Sorry to bump but don't know if anyone saw this. Still wondering if it's a bug or am I missing something to make it work properly? Thanks.
B
16
S
2
G
1
Posts: 28
Reputation: 1,346

Post » Mon Jan 30, 2012 6:20 am

Same deal. I experience this mostly with the car behavior, in which if i drive in reverse to the outside the screen it jitters/go's wacky.

Also, if you don't mind me suggesting. A margin property for the wrap would be great.PixelPalette2012-01-30 06:21:55
B
50
S
11
G
7
Posts: 274
Reputation: 8,146

Post » Sat Apr 21, 2012 9:58 pm

Same here. Some items in my game are going off the edge and not coming back on the other side. I noticed it when I set the layout to be full screen (scale). If you play the level every so often you can see an enemy sprite just going up (or down) a channel off screen. Weirdly they may suddenly 'jump' on screen for no reason. Hope seeing this might help?

Using latest build btw (RLS 87)

http://dl.dropbox.com/u/74633005/ast.capxvandinz2012-04-21 22:00:18
B
19
S
5
G
4
Posts: 208
Reputation: 3,960

Post » Wed May 02, 2012 10:37 am

@vandinz can you reproduce the problem in a new project?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests