Xaudio causing crashes?

For questions about using Classic.

Post » Thu Aug 27, 2009 3:24 pm

I'm getting sorta-random crashes in my game, and I'm finding a pattern that they tend to happen at times when the music changes (oggs played via autoplay or reserving a channel). I can't submit a .cap because I can't make it happen each time, and each time it happens is at a different place. The only thing in common with them are the xaudio events.

Anyone else getting these crashes?
Moderator
B
93
S
33
G
33
Posts: 3,006
Reputation: 27,719

Post » Thu Aug 27, 2009 11:14 pm

I've noticed this also, but it's tough to pinpoint. I can't say exactly where/why it happens.
B
41
S
8
G
9
Posts: 1,219
Reputation: 8,064

Post » Fri Aug 28, 2009 6:47 am

that plugin hates me, and feeling is mutual

crashes are less in new versions, but have it happened to me couple of times on older versions
B
24
S
7
G
3
Posts: 138
Reputation: 2,795

Post » Fri Aug 28, 2009 9:57 am

Does it still happen if you make the channel stop before playing another file on it?
B
3
S
1
G
3
Posts: 82
Reputation: 1,189

Post » Fri Aug 28, 2009 2:24 pm

It's difficult to do anything about it unless you can have a reliable way to reproduce the problem, I'm afraid...
Scirra Founder
B
386
S
229
G
87
Posts: 24,207
Reputation: 191,682

Post » Fri Aug 28, 2009 3:52 pm

I was talking with someone about it and the suggested something about core dumps? Do games made with construct make core dumps?
Moderator
B
93
S
33
G
33
Posts: 3,006
Reputation: 27,719

Post » Sat Aug 29, 2009 1:46 pm

I don't think they're useful.
Scirra Founder
B
386
S
229
G
87
Posts: 24,207
Reputation: 191,682


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 5 guests