XBOX 360 controller/object problems in Construct

For questions about using Classic.

Post » Sun Jan 17, 2010 9:41 pm

Hello,

I've been testing some different things in Construct to try and learn it. RIght now I'm testing the 360 controller object and I've encountered a number of issues. Let me preface by saying that my XBOX 360 controller works perfectly with every Windows game I have, works perfectly with my XBOX 360 machine, and using the Windows controller calibration it shows that all buttons work properly.

In Construct however, I get the following (the issues are in #'s 3 through 8 ):

Test #1: Make the program jump to another layout when pressing "Down" on the dpad, and "A", simulataneously.

Listing method:

Event = Button A is down
New condition = Dpad down is down

Result: Success, it jumps to another layout.

======================================

Test #2: Make the program jump to another layout when pressing "Left" on the dpad, and "B", simulataneously.

Listing method:

Event = Button B is down
New condition = Dpad Left is down

Result: Success, it jumps to another layout.

======================================

Test #3: Make the program jump to another layout when pressing "Right" on the dpad, and "X", simulataneously.

Listing method:

Event = Button X is down
New condition = Dpad Right is down

Result: It does nothing.

======================================

Test #4: Make the program go to another layout when pressing "Up" on the dpad, and "Y", simulataneously.

Listing method:

Event = Button Y is down
New condition = Dpad Up is down

Result: It does nothing.

Note: The Y button and the X button appear to be completely inoperable, while A, B, the shoulders and the triggers work fine.
=======================================

Test #5: Make the character do something via commands on the left analog stick

Listing Method:

Event = Left thumb Up is down

Result: It does nothing. However, when I begin to press the 'X' button wildly it then does the desired operation.

======================================

Test #6: Make the character kick via command on the right analog stick

Listing method:

Event = Right thumb Up is down + Sprite: Set animation to "Kick"

Result: The right stick does not respond. However, when I push "left" on the left stick the animation plays.

======================================

Test #7: Move forward to another layout (like a menu) and move back using the "Start" button.

Listing method:

Event = start is down + Go to layout "Pause Menu"

Result: It goes to the "Pause Menu" layout.

======================================

Test #8: Move back to the game layout from the "Pause Menu" using the 'start' button.

Listing method:

Event = start is down + Go to layout "Game layout"

Result: It does nothing. However, when I use the 'back" button in the event instead of 'start', it works.
B
2
G
2
Posts: 47
Reputation: 744

Post » Mon Jan 18, 2010 2:57 am

If something like this happens you should post a bug report to the tracker along with a cap demonstrating the problems. Threads like these usually go by the way side. so yeah post a bug report with a cap.
B
5
S
2
G
4
Posts: 632
Reputation: 2,829

Post » Mon Jan 18, 2010 3:38 am

Yeah, I may do that. But the thing I'm most curious about is if these are all known issues and others are having the same problem?

I don't see a lot said about the 360 controller object. Could it be because so few people have used it here that it's not made much of an issue? Or is it because lots of people have used it and found the same issues and gave up on it? I don't know, that's what I'm curious about.

If anyone could tell me if they've had the same issues, or some solutions to the issues I've described, please let me know. Right now, it just seems like the object may be broken. It just wouldn't make sense for a command to work properly for two buttons, but the same command for two other buttons does nothing.

P.S. I should mention that I just re-did all of the commands I described using the Keyboard object and they all work perfectly fine. But the 360 controller object still doesn't do them.
B
2
G
2
Posts: 47
Reputation: 744

Post » Mon Jan 18, 2010 4:25 am

Controller works fine for me so far, but yeah if you think it's bugged, adding it to the tracker is the best bet.
B
3
S
2
G
3
Posts: 628
Reputation: 2,531


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 0 guests