XBOX ONE UWP performance?

Post » Wed Jul 19, 2017 11:26 pm

So i have an xbox one lying around since Christmas not doing much. PS4 and PC are the current platforms of choice in my household.

But anyway tonight thought i would sign up the £12 for a dev licence. Downloaded visual studio. Put the dev app on the xbox. Use the uwp export in construct 3. With not much faffing around got the game deployed to xbox one.

All that beautiful gaming specific hardware gave me

15 fps ????!!!!

This is a game that funs 60 in i5 with integrated and runs 40-60 on most phones.....

Is this the reality of uwp on xbox one ????

Are there some settings im missing

It says its running web gl

But The cpu is going to 90%+ would normally be 20% on my pc and maybe 40% on phones so....

Wtf?
Last edited by NetOne on Sun Jul 23, 2017 11:26 pm, edited 3 times in total.
...
B
42
S
21
G
7
Posts: 260
Reputation: 7,683

Post » Wed Jul 19, 2017 11:39 pm

You're supposed to turn on the thing next to the thing, beside the other whatyamacallit.
Its right under it.
Image ImageImage
B
168
S
50
G
163
Posts: 8,220
Reputation: 105,059

Post » Wed Jul 19, 2017 11:56 pm

@Newt, behave... xbox one was going to be my path to glory,,, no more working for the man... beach side property... lambo on the drive... full entourage of playboy models catering to my every need..... then ..... 15 frames per second ..... god damn it...
...
B
42
S
21
G
7
Posts: 260
Reputation: 7,683

Post » Thu Jul 20, 2017 1:46 am

If only there was some way to tell or show us what you did, minus the Lamborghini, and entourage.
Have you tried turning it off then back on again?
Image ImageImage
B
168
S
50
G
163
Posts: 8,220
Reputation: 105,059

Post » Thu Jul 20, 2017 4:57 am

NetOne wrote:@Newt, behave... xbox one was going to be my path to glory,,, no more working for the man... beach side property... lambo on the drive... full entourage of playboy models catering to my every need..... then ..... 15 frames per second ..... god damn it...

Image
B
81
S
26
G
9
Posts: 244
Reputation: 10,616

Post » Thu Jul 20, 2017 7:37 am

UWP doesn't have full access to the hardware, so native or not that's a big let-down. I think the Edge browser also has some issues with HTML5 games still.

Your experience sounds an awful lot like the exporting option to a certain Nintendo product in C2 .... :o
"Construct 4 lets YOU make advanced games! (but not play them)" Construct Classic - Examples Kit
B
113
S
39
G
17
Posts: 2,183
Reputation: 19,215

Post » Thu Jul 20, 2017 1:31 pm

NetOne wrote:But The cpu is going to 90%+ would normally be 20% on my pc and maybe 40% on phones so....

Sounds like the game is CPU-bound so you should take a look in the debug profiler back in C2 and see what the busiest areas are. You can also run it on Edge on Windows and see how that compares.

IIRC the latest Edge update does improve JS performance a lot, but I'm not sure if that update has made it to the Xbox One yet.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,216

Post » Thu Jul 20, 2017 3:34 pm

Here's some information on what you can expect with UWP apps & games on Xbox One: https://docs.microsoft.com/en-us/windows/uwp/xbox-apps/system-resource-allocation
B
40
S
21
G
18
Posts: 153
Reputation: 12,308

Post » Thu Jul 20, 2017 3:37 pm

hi @ashley

out of curiosity why are you interested in edge performance?

does UWP run js through edge ?

on my dev PC (surface pro i5 with integrated graphics) my game runs beautifully on edge, 60fps/20-40%cpu, butter smooth, feels even better than Chrome.

so it must be down to some possible bad settings or a combination of the xbox UWP hardware restrictions and whatever way UWP handles the JS code.

In the name of scientology I will try another test this weekend.
...
B
42
S
21
G
7
Posts: 260
Reputation: 7,683

Post » Fri Jul 21, 2017 6:08 am

NetOne wrote:In the name of scientology I will try another test this weekend.


Image
B
81
S
26
G
9
Posts: 244
Reputation: 10,616

Next

Return to General Discussion

Who is online

Users browsing this forum: rhg1968 and 0 guests