Page 14 of 14

Re: Yet-another Multiplayer Demo

PostPosted: Mon Jul 22, 2013 4:32 pm
by nutmix
Hi Rex.

I have tried both the official websocket and Zacks socketio plugin, and neither work (neither try and make any connection, nor send any data, nor repsond to any message).

Do you have a general purpose socket.io plugin which you use? I looked at your list of plugins, and you only seem to have lobby, bottleneck and chat plugins, not one I can use.

I have a very simple test node.js app:

var io = require("socket.io").listen(8080);
io.sockets.on('connection', function (socket) {
    console.log("connected");
    socket.emit('balls', { ball:42 });
    socket.on('daub', function (data) {
      console.log(data);
    });
});

And if I hit it with a simple js page:

<html>
<head>
</head>
<body>
<script src="socket-io/socket.io.js"></script>
<script>
var socket = io.connect('http://localhost:8080');
socket.on('balls', function (data) {
    console.log(data);
    socket.emit('daub', { my: 'data' });
});
</script>
</body>
</html>

It works perfectly. But i have yet to find any socketio or web socket plugin which will work (or even connect), e.g. this doesnt:

System=>On start of layout: Socket - Connect to "ws://localhost" (set to 8080 in dialogue)

does not make, or attempt to make, any connection to node server.

Re: Yet-another Multiplayer Demo

PostPosted: Tue Jul 23, 2013 3:24 am
by rexrainbow
@nutmix

The bottleneck and lobby are not general purpose socket.io plugin. They are made for my game server.

Re: Yet-another Multiplayer Demo

PostPosted: Fri Sep 27, 2013 7:25 pm
by breackzin
@rexrainbow, I will be looking your server again this October, trying to understand what is so wrong with my own.

Could you tell me what yours "console.log('app listening on http://' + addr.address + ':' + addr.port);" show to you in your logs?

My server works on foreman and I manage to keep my previews connected on it locally, but once I produce the server package and push it to heroku, It logs "app listening on http://0.0.0.0:30801" and I can not manage to connect on it.

Also, some "code=H12 desc="Request timeout"" appears on my logs.breackzin2013-09-27 19:49:54

Re: Yet-another Multiplayer Demo

PostPosted: Sun Feb 02, 2014 6:00 pm
by j2l
I wanted to test bottleneck but it looks like all links to p1ay.allalla.com are dead now.
Is there another source somwhere?

Re: Yet-another Multiplayer Demo

PostPosted: Mon Mar 24, 2014 10:40 am
by rexrainbow