The Construct 2 Interface

The following diagram highlights the important parts of the Construct 2 user interface. An overview of each part is provided below, and later the manual goes in to each section in more detail.

Construct 2 interface


1: File menu and Ribbon tabs

http://www.scirra.com/images/articles/qat2.png
Construct 2 uses a ribbon interface, which is like a tabbed toolbar similar to Office 2007 and newer. The blue button with the drop-down arrow is the File menu, and to the right of that are ribbon tabs which drop down the ribbon bar with various buttons and options.

There's also the quick-access toolbar with the four most commonly used commands: Save, Undo, Redo, Preview and Debug. You can add and remove buttons to this toolbar yourself: click the small drop-down arrow to its right to customise it. If you want to have a lot of commands in this toolbar you can also opt to have it shown beneath the ribbon.

2: The Layout view

This is a visual editor where you place objects to design levels, menu screens and so on. See The Layout View.

3: View tabs

View tabs
These tabs allow you to switch between different layout views and event sheet views, to define the event-based logic of the game.

You can click and drag a tab in to one of the views to set up a side-by-side split screen view.

4: The Properties Bar

In this bar you will see a list of properties depending on what you have clicked on. You can view and change properties for things like layouts, objects, layers and more. See The Properties Bar.

5: Project Bar and Layers Bar

By default the Project Bar and Layers Bar are tabbed here. The Project Bar contains an overview of everything in your project. The Layers Bar can be used to add different layers to a layout.

6: Project Bar/Layers Bar tabs

Bar tabs
These allow you to switch between the Project Bar and Layers Bar.

7: Object Bar

This contains a list of objects in your game. You can drag and drop objects from here to place them in layouts. The right-click menu has many options to filter or display the objects differently. See The Object Bar.

8: Status Bar

At the bottom of the editor window is the Status Bar. This shows:

  • what Construct 2 is currently doing during a long-running task, like exporting or saving the project
  • how many events are in the project and its approximate filesize
  • the current active layer, which is the layer new objects are placed on to
  • the mouse position in layout co-ordinates
  • the current zoom level.

9: Top-right buttons

Ribbon top-right buttons
As well as the usual Windows minimise, maximise and close buttons, there's also the Pin Ribbon button to force the ribbon to always be showing, and the About button to open the About dialog with information and credits for Construct 2.

Customising

You can customise the interface to suit your tastes. Any of the bars can be dragged and dropped to different positions in the editor window. Also, you can auto-hide bars to save room: click the pin icon on a bar and it will shrink to a simple tab. Hover the tab to pop open the bar.

Bars can be hidden and shown in the View ribbon tab.

You can create a split-screen view by clicking and dragging one of the layout or event sheet tabs in to the main view. This can be useful on large monitors.

Tags: